Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 06, 2025 - 16:00 UTC
Scheduled
We're currently upgrading our Mac infrastructure. You might experience tests to take longer to start running or behave inconsistently during that time window.
Posted Mar 06, 2025 - 15:57 UTC
This scheduled maintenance affected: app.maestro.dev (Background Processing).