Elevated errors when uploading new test runs

Incident Report for mobile.dev

Monitoring

The issue was a conflict between business logic and a database data migration. A fix has been applied and we're monitoring the system.
Posted Mar 24, 2026 - 10:15 UTC

Identified

A number of users have reported errors returned from the Maestro Cloud API. Seen in CLI, Studio and GitHub Actions when starting new uploads.
Posted Mar 24, 2026 - 09:00 UTC
This incident affects: API.