Maestro Cloud dashboard and results unavailable

Incident Report for mobile.dev

Resolved

Third party systems restored. Maestro Cloud access it back to normal.
Posted Jul 16, 2026 - 11:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 11:03 UTC

Identified

Our systems are affected by an outage at our identity provider, WorkOS. https://status.workos.com/incidents/b52fkqjzcl20
Posted Jul 16, 2026 - 10:09 UTC
This incident affected: app.maestro.dev (Dashboard).