iOS16 devices pool became unavailable due to internal issues with freeing up a device

Incident Report for mobile.dev

Resolved

The incident has been resolved. Several fixes applied to make sure iOS device pools are more robust against parallel flow runs and higher load.
Posted Aug 02, 2023 - 14:30 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 02, 2023 - 14:28 UTC

Monitoring

Redeploy was done after which the issue has been automatically resolved
Posted Aug 02, 2023 - 11:47 UTC
This incident affected: Upload processing.