Flow processing degradation
Incident Report for mobile.dev
Resolved
The incident has been resolved and processing is back to normal.
Posted Jun 20, 2023 - 11:58 UTC
Monitoring
We have scaled up our infra and are working through the queue of Flows. We expect to be back to normal operations in roughly one hour.
Posted Jun 20, 2023 - 11:05 UTC
Investigating
We are currently experiencing an extreme load on our systems and turnaround time of Flows will be impacted as a result. We're monitoring the situation closely and work to scale our infrastructure to support the increased load.
Posted Jun 20, 2023 - 10:47 UTC
This incident affected: Maestro Cloud (Upload processing).